Поддержка старых браузеров

Опубликовано 08.06.2017 в разделе «Заметки»

Как в wordpress сохранить функциональность сайта для устаревших браузеров?

В functions.php вставляем следующее:

Список можно и нужно менять в зависимости от специфики вашего сайта.

А затем в нужном месте выбираем, что нужно выдать, в зависимости от определенного браузера, используя вот такой код:

И вот, например, список проблемных браузеров (для моего сайта):

  • Opera/9.80 (Windows NT 6.2; WOW64) Presto/2.12.388 Version/12.15
    Top of Page
  • Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 YaBrowser/16.2.1.7529.00 Safari/537.36
  • Opera/9.80 (Android; Opera Mini/15.0.2125/37.8314; U; ru) Presto/2.12.423 Version/12.16
  • YaBrowser (имеет своё мнение на междустрочные интервалы, но возможно это не баг, а фича)
  • Все IE до 9 версии
Вернуться обратно в Заметки или на главную?